<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":330,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81766903-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>OrangeandBlueNews.com  -  Supinie: Illini football recruiting has some juice</title>
<meta content='OrangeandBlueNews.com  -  Supinie: Illini football recruiting has some juice' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-42736c1a7eb2a694d80bae23270ea1b0c5d5da44d33cc12c90aec89380ed21f5.css" />

<script src="https://cdn.rivals.com/production/assets/application-1192834571c64be74f40c174e62f4a16bd5be09f451ac0b083467411d00857c8.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="hEBxHmEpurjpOeWClSIO42otLX1H7fZNnEPAqxsui8aDzQfUcXsXGfmZH0m45zVsTW109OSG7NLaMpPpEm4nKA==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/gaevsjdvq9qqnjcu2edy' property='og:image'>
<meta content='Is this the start of something big? Illinois football is creating buzz on the recruiting trail this spring. ' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-22 17:34:08 -0500' property='article:published_time'>
<meta content='2018-03-22 17:34:09 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "illinois.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='illinois contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .illinois #programming > h1 {
      background-color: #14284b !important; } }
  .illinois > header .notification-link .count-container {
    background-color: #14284b !important; }
  .illinois > header .wrapper-container {
    background-color: #14284b !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .illinois > header .wrapper-container {
        border-bottom: 5px solid #EA503A !important; } }
  .illinois > header .invalid-email-banner {
    background-color: #14284b;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .illinois > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .illinois > header .invalid-email-banner a:hover {
      color: #EA503A; }
  @media screen and (max-width: 767px) {
    .illinois > header .mobile-header {
      background-color: #EA503A !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .illinois > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .illinois > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .illinois > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .illinois > header .nav-row > ul,
    .illinois > header .third-nav {
      background-color: white !important; }
    .illinois > header .dropdown-toggle > i.fa {
      color: #14284b !important; } }
  .illinois > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #14284b; }
  
  .site-primary-font-color {
    color: #14284b; }
  
  .site-primary-background-color {
    background-color: #14284b; }
  
  .site-secondary-font-color {
    color: #EA503A; }
  
  .site-secondary-background-color {
    background-color: #EA503A; }
  
  :root {
    --outbrain-primary-color: #14284b;
    --outbrain-secondary-color: #EA503A; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Illinois" class="school-header" href="//Illinois.rivals.com"><img src="https://res-4.cloudinary.com/rivals/image/upload/gtepa0s3ywzelafatafp" alt="Gtepa0s3ywzelafatafp" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//Illinois.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;illinois&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//Illinois.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;illinois&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733101,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Supinie: Illini football recruiting has some juice"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='IllinoisRivals' name='twitter:site'>
<meta content='Supinie: Illini football recruiting has some juice' name='twitter:title'>
<meta content='Is this the start of something big? Illinois football is creating buzz on the recruiting trail this spring. ' name='twitter:description'>
<meta content='https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gaevsjdvq9qqnjcu2edy' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1906710,"title":"The 3-2-1: Decision on tap for Williams","slug":"the-3-2-1-decision-on-tap-for-williams","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-22T09:06:46.078-05:00","summary":"In the latest edition of the 3-2-1, we dissect the looming decision of 4-star athlete Isaiah Williams. ","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/the-3-2-1-decision-on-tap-for-williams","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1906715,"title":"DE Randolph is a state champ","slug":"de-randolph-is-a-state-champ-1","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-22T09:19:44.637-05:00","summary":"Belleville (Ill.) West defensive end Keith Randolph just took home an IHSA state basketball championship","deleted":false,"author_name":"Tim OHalloran","author_title":"EdgyTim.com","permalink":"https://illinois.rivals.com/news/de-randolph-is-a-state-champ","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1906116,"title":"Rivals150 forward Hinson reclassifies, names favorites","slug":"rivals150-forward-hinson-reclassifies-names-favorites","kind":"premium","site_id":49,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-20T17:28:15.597-05:00","summary":"As long expected, four-star forward Blake Hinson from Bel Aire (KS) Sunrise Christian is reclassifying to 2018.","deleted":false,"author_name":"Kedric Prince","author_title":"Recruiting contributor","permalink":"https://illinois.rivals.com/news/rivals150-forward-hinson-reclassifies-names-favorites","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905973,"title":"JUCO forward Trice trims list to six","slug":"juco-forward-trice-trims-list-to-six","kind":"premium","site_id":49,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-20T11:53:18.527-05:00","summary":"Three-star power forward Austin Trice from Wabash Valley C.C. breaks down his top six. ","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/juco-forward-trice-trims-list-to-six","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1906068,"title":"Baylor commit Jaylen Ellis may visit Illinois","slug":"baylor-commit-jaylen-ellis-may-visit-illinois","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-20T15:36:06.209-05:00","summary":"Round Rock (Texas) Cedar Ridge wide-receiver Jaylen Ellis received an offer from Illinois.   ","deleted":false,"author_name":"Jonah Puls","author_title":"Recruiting contributor","permalink":"https://illinois.rivals.com/news/baylor-commit-jaylen-ellis-may-visit-illinois","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905938,"title":"Take Two: Will Illinois be able to keep Rivals100 ATH in the fold?","slug":"take-two-will-illinois-be-able-to-keep-rivals100-ath-in-the-fold--1","kind":"free","site_id":49,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-20T10:40:25.542-05:00","summary":"Marquez Beason is a four-star athlete who’s ranked No. 78 nationally. He committed to Illinois last week. ","deleted":false,"author_name":"Adam Gorney","author_title":"Recruiting Analyst","permalink":"https://illinois.rivals.com/news/take-two-will-illinois-be-able-to-keep-rivals100-ath-in-the-fold-","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905400,"title":"Illinois reaches out to three-star DT Lloyd Murray","slug":"murray-1015","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-18T17:01:43.377-05:00","summary":"Illinois reached out on Sunday to three-star defensive tackle Lloyd Murray from Wichita Falls (Texas) Hirschi","deleted":false,"author_name":"Jonah Puls","author_title":"Recruiting contributor","permalink":"https://illinois.rivals.com/news/murray-1015","site_name":"OrangeandBlueNews.com","type":"Content","programming":[49],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1808431,"title":"2018 Illinois football depth chart","slug":"2017-illinois-football-depth-chart","kind":"premium","site_id":49,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-22T14:29:58.033-05:00","summary":"Illinois football depth chart for 2018","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/2017-illinois-football-depth-chart","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1801745,"title":"Illinois basketball scholarship grid","slug":"illinois-basketball-scholarship-grid-1","kind":"premium","site_id":49,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-20T14:05:53.077-05:00","summary":"Illinois basketball interactive scholarship grid and offer list","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/illinois-basketball-scholarship-grid-1","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905940,"title":"Twitter Tuesday: Ramey&#x0027;s future; fixing Pitt; IU&#x0027;s top targets","slug":"twitter-tuesday-ramey-s-future-fixing-pitt-iu-s-top-targets-1","kind":"premium","site_id":49,"sport":"basketball","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-20T10:43:19.386-05:00","summary":"Following a tremendous opening weekend of the NCAA Tournament, we get to your questions in this week’s #TwitterTuesday","deleted":false,"author_name":"Corey Evans","author_title":"Basketball Analyst","permalink":"https://illinois.rivals.com/news/twitter-tuesday-ramey-s-future-fixing-pitt-iu-s-top-targets","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1764076,"title":"The Block I Report:  Isaiah Williams a key to Illini class","slug":"the-block-i-report-in-state-targets-at-the-forefront","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-19T16:38:13.684-05:00","summary":"St. Louis Trinity Catholic  quarterback Isaiah Williams tops the Illinois recruiting board  ","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":1570,"url":"https://illinois.rivals.com/offers/football/2019","display_text":"Illinois offer list","content_id":1764076,"created_at":"2017-04-11T23:30:26.113-05:00","updated_at":"2018-02-07T20:51:00.574-06:00","setting_id":null,"ordinality":1},{"id":1571,"url":"https://n.rivals.com/team_rankings/","display_text":"2018 team rankings","content_id":1764076,"created_at":"2017-04-11T23:30:26.116-05:00","updated_at":"2017-04-11T23:30:26.116-05:00","setting_id":null,"ordinality":2}]},{"id":1905379,"title":"Three-star linebacker Tristan Sinclair holds Illini offer","slug":"tristan-sinclair-3","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-19T14:24:54.589-05:00","summary":"Illinois recently offered 3-star linebacker Tristan Sinclair from Danville (Calif.) San Ramon Valley","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/tristan-sinclair-3","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905715,"title":"Five Midwest up-and-comers to watch in Spring Evaluation Period","slug":"five-midwest-up-and-comers-to-watch-in-spring-evaluation-period","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-19T13:42:41.271-05:00","summary":"These five Midwest prospects are poised to see their recruitments take off in the next couple months.","deleted":false,"author_name":"Josh Helmholdt","author_title":"Recruiting Analyst","permalink":"https://illinois.rivals.com/news/five-midwest-prospects-to-watch-in-recruiting-wars-this-spring","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905348,"title":"RCS Houston: Rivals100 DB Erick Young working toward decision","slug":"rcs-houston-rivals100-db-erick-young-working-toward-decision-1","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-18T13:19:09.444-05:00","summary":"Find out which schools are in the mix for  Rivals100 DB Erick Young","deleted":false,"author_name":"Nick Krueger","author_title":"Recruiting Analyst","permalink":"https://illinois.rivals.com/news/rcs-houston-rivals100-db-erick-young-working-toward-decision","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1905129,"title":"The Wire:  Fearless predictions","slug":"the-wire-fearless-predictions","kind":"premium","site_id":49,"sport":"basketball","news_type":"recruiting","content_type":"Content::ForumThread","live_at":"2018-03-17T16:53:40.661-05:00","summary":"OrangeandBlueNews predicts where top Illini basketball and football prospects are headed, including Tevian Jones","deleted":false,"author_name":"Staff","author_title":"OrangeandBlueNews","permalink":"https://illinois.rivals.com/news/the-wire-fearless-predictions","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904121,"title":"OL Broeker checks out Illini junior day","slug":"ol-broeker-checks-out-illini-junior-day","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-17T15:57:42.431-05:00","summary":"Three-star offensive lineman Nick Broeker from Springfield (Ill.) Sacred Heart-Griffin recently visited Illinois.  ","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/ol-broeker-checks-out-illini-junior-day","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904827,"title":"Childress could make return trip to Illinois","slug":"childress-could-make-return-trip-to-illinois","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T12:39:12.200-05:00","summary":"St. Louis (MO) Trinity Catholic wide-receiver Bryce Childress would like to make a return trip Champaign for a visit","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/childress-could-make-return-trip-to-illinois","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904775,"title":"Bloomington tight end Griffin Moore commits to Illinois","slug":"bloomington-tight-end-griffin-moore-commits-to-illinois","kind":"free","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T11:10:38.933-05:00","summary":"Illiinois picked up a commitment on Friday from two-star right end Griffin Moore from Bloomington (Ill.)","deleted":false,"author_name":"Doug Bucshon","author_title":"Publisher","permalink":"https://illinois.rivals.com/news/bloomington-tight-end-griffin-moore-commits-to-illinois","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904455,"title":"Future Illini Ayo Dosunmu leads Morgan Park back to Peoria","slug":"future-illini-ayo-dosunmu-leads-morgan-park-back-to-peoria","kind":"free","site_id":49,"sport":"basketball","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T13:52:49.947-05:00","summary":"Morgan Park and Ayo Dosunmu play Marian Catholic in the state semifinals on Friday at Carver Arena in Peoria","deleted":false,"author_name":"John Supinie","author_title":"Columnist","permalink":"https://illinois.rivals.com/news/future-illini-ayo-dosunmu-leads-morgan-park-back-to-peoria","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904427,"title":"LB Shammond Cooper names top 10, talks recruiting","slug":"lb-cooper-names-top-10-talks-recruiting","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T12:04:22.277-05:00","summary":"St. Louis (MO) Trinity Catholic inside linebacker Shammond Cooper named a top 10 on Thursday","deleted":false,"author_name":"Jonah Puls","author_title":"Recruiting contributor","permalink":"https://illinois.rivals.com/news/lb-cooper-names-top-10-talks-recruiting","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904243,"title":"Illini pursuing Rivals250 defensive lineman Jaquaze Sorrells","slug":"illini-pursuing-rivals150-defensive-lineman-jaquaze-sorrells","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-14T17:12:13.485-05:00","summary":"Illinois would like to secure a visit from four-star defensive tackle Jaquaze Sorrells from Largo (Fla.)","deleted":false,"author_name":"Jonah Puls","author_title":"Recruiting contributor","permalink":"https://illinois.rivals.com/news/illini-pursuing-rivals150-defensive-lineman-jaquaze-sorrells","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]},{"id":1904133,"title":"Rivals100 CB Erick Young wants to visit Illinois","slug":"rivals100-cb-erick-young-wants-to-visit-illinois","kind":"premium","site_id":49,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-14T14:11:15.638-05:00","summary":"Illinois offered 4-star cornerback Erick Young from Richmond (Texas) Bush on Tuesday.","deleted":false,"author_name":"Jonah Puls","author_title":"Recruiting contributor","permalink":"https://illinois.rivals.com/news/rivals100-cb-erick-young-wants-to-visit-illinois","site_name":"OrangeandBlueNews.com","type":"Content","programming":[],"associated_links":[{"id":2086,"url":"https://illinois.rivals.com/news/the-block-i-report-basketball","display_text":"Top basketball prospects","content_id":null,"created_at":"2017-06-15T12:29:23.184-05:00","updated_at":"2017-06-15T12:29:23.184-05:00","setting_id":59,"ordinality":1},{"id":2087,"url":"https://illinois.rivals.com/news/the-block-i-report-in-state-targets-at-the-forefront","display_text":"Top football prospects","content_id":null,"created_at":"2017-06-15T12:29:23.186-05:00","updated_at":"2017-06-15T12:29:23.186-05:00","setting_id":59,"ordinality":2}]}], nil, 49, nil, true); subdomain = &#x0027;illinois&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #14284b'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":112,"image_id":1796724,"url":"https://seatgeek.com/illinois-fighting-illini-football-tickets","position":1,"site_id":49,"created_at":"2016-04-06T09:18:14.037-05:00","updated_at":"2017-06-29T15:25:11.252-05:00","image_url":"https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/pejibwu5z93wcphtcsl1"}' class='ad-one'></rv-custom-ad>

<rv-homepage-forums ad-referer='https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice' background-color='#14284b' base-api-url='https://illinois.forums.rivals.com/' homepage='false' message-board-url='illinois.forums.rivals.com' pub-ad='null' size='size' space-id='2022733101' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice/printable' site-name='OrangeandBlueNews.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-22 17:34:08 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1906929/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Supinie: Illini football recruiting has some juice</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
John Supinie
&bull;
</span>
<span class='type-sm'>OrangeandBlueNews.com</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Columnist</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><b>CHAMPAIGN –</b> Is this the start of something big?</p><p>That’s the question surrounding Illini football. After the hiring of former St. Louis Trinity Catholic coach Cory Patterson this spring and a big commitment from Texas, recruiting has some juice. It’s much too early to call it a trend, but there’s some anticipation as the Illini quietly work through spring football drills.</p><p>It’s no secret the Illini need more players and playmakers to jump-start a program heading into the third season under coach Lovie Smith. The first two recruiting classes were pedestrian, according to the national rankings. The Illini identified some talent that worked its way into the depth chart last season as freshmen, but there’s a different feel this spring among observers who have followed the program long term.</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gaevsjdvq9qqnjcu2edy)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gaevsjdvq9qqnjcu2edy" alt="Gaevsjdvq9qqnjcu2edy" />
</div>
<figcaption class='image-caption'>Illinois could  be on the verge of landing another Isaiah Williams</figcaption>
<div class='image-credit'>Fighting Illini Athletics</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>And, of course, everyone is waiting for an answer from <a href="https://n.rivals.com/content/prospects/2019/isaiah-williams-96143">Isaiah Williams</a>, Rivals100 kid from Trinity Catholic ranked No. 37 nationally in his class with a list of college football heavyweights who has hinted there’s news coming Friday. Does he trim the list that currently stands around 40? Does he make a commitment? Either way, the Illini feel confident of their chances to land him.</p><p>“They’re turning the corner,’’ said Decatur Herald &amp; Review columnist Mark Tupper. “They’re getting a different kind of kid to visit. They’re getting a different kind of kid to commit. To start off the class with a four-star and a five-star, plus the tight end from Bloomington, would be a great start for the Illini. They appear to be getting real traction on the recruiting front in the areas they’ve targeted, such as Texas, St. Louis, Florida, Illinois and now getting more involved in California with Rod Smith, Hardy Nickerson and Austin Clark.’’</p><p>Four-star athlete <a href="https://n.rivals.com/content/prospects/2019/marquez-beason-182915">Marquez Beason</a> of Bishop Dunne High School in Dallas already gave the Illini a commitment, even though Illinois appeared overshadowed on a list of finalists that also included LSU, Texas A&amp;M and Ohio State. Beason followed two other Dunne stars, including defensive tackle Calvin Avery, to the Illini, and his cousin, Zeriah, might follow next season.</p><p>Beason is ranked No. 78 in his class nationally and would stand as the highest rated recruit to sign with the Illini since <a href="https://n.rivals.com/content/prospects/2009/terry-hawthorne-54675">Terry Hawthorne</a> from East St. Louis in 2009. You remember those days, right? That’s when the Zooker and his staff filled the roster with NFL-type talent.</p><p>During the recent junior day, “that was the most recruiting buzz I’d felt in a long time, since Zook and (Mike) Locksley and that D.C. pipeline,’’ Tupper said. “There was a lot of buzz then, and it translated into a Rose Bowl trip. This staff is different than anything we’ve seen recently with the Illini.’’</p><p>While running backs coach Thad Ward and Patterson have apparently taken a lead role in much of the Illini recruiting and Andrew Hayes-Stoker works the Dallas area, Illinois is also trying to sell the NFL experience compiled by men on the Illini staff. After the hiring of defensive assistant Gil Byrd, there’s roughly 60 years of NFL coaching experience.</p><p>“Ward really gets it on the recruiting front,’’ Tupper said. “He’s really started to establish himself as a guy who can bring in players. Rod Smith gets it. The kids respond to him, and he’s got the California connections. Corey Patterson is a young guy, a social media guy, who had a program full of good kids.</p><p> “Lovie is also marketing himself and his staff and those cumulative years in the NFL. They have over 60 years in the NFL, the most in the country. Beason told me he wanted to be coached by guys who know how to get me to the NFL.’’</p><p>Early success often creates more success, so the Illini hope Beason can help whip up interest with the Illini. Evidently, Zeriah Beason was also ready to commit as one of the top recruits in the class of 2020.</p><p>But, as Zooker learned, it’s hard to keep winning big on the recruiting trail if you don’t start winning big on Saturdays. Illinois is 5-19 under Lovie, and showing a pulse this fall is becoming critical.</p><p> “At some point, you have to back it up with victories,’’ Tupper said. “You need some evidence all of this NFL experience translates into wins here.’’</p><p>Illinois’ struggles over the first two years under Lovie left some recruiting analysts wondering if the commitment from Beason will stick.</p><p>“It’s one of those commitments where you look at it and say there’s no way this one is going to stick,’’ said Rivals.com national recruiting analyst Mike Farrell. “But he does have two teammates from Bishop Dunne who signed last year including Avery, whom he’s very, very tight with. The coaching staff does an excellent job recruiting that area. Logic would tell you a lot of bigger schools will come in, especially if Illinois has a bad season, and take him away. If he does stick, you’ll see his cousin go there. He’ll have plenty of opportunities as well, but blood is thicker than anything else.</p><p>“That’s why this commitment is so important to keep. If they can keep Beason and then they can get his cousin, they will really get some momentum going down in the Dallas area.’’</p><p>But this is recruiting season, and wins here often turn into wins this fall. That makes any news tomorrow from Williams important as Illini football recruiting is gaining some traction – and confidence.</p><p> “The feeling over there (in Champaign) is they’re going to get a commitment from this kid,’’ Tupper said.</p><p>If so, Illini football recruiting would be a player.</p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p><i>John Supinie is a columnist for Orangeandbluenews.com. During the day, he’s an Audi Brand Specialist at Green Audi in Springfield. Call or text him at 217-377-1977 if you’re looking for an Audi, Volkswagen, Toyota or preowned car. Ask for the Illini deal.</i></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice/printable' site-name='OrangeandBlueNews.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":49,"legacy_id":922,"name":"OrangeandBlueNews.com","friendly_name":"Illinois","annual_discount":null,"subdomain":"illinois","primary_color":"14284b","secondary_color":"EA503A","font_color":"ffffff","short_name":"Illinois","maple_ncaaf_team_id":26,"maple_ncaaf_endpoint":"ncaaf/teams/iic","maple_ncaab_team_id":267,"maple_ncaab_endpoint":"ncaab/teams/iae","maple_college_id":26,"google_analytics_id":"UA-81766903-1"}' twitter-feed='{"id":49,"site_id":49,"handle":"IllinoisRivals","list_name":"orange-and-blue-news","created_at":"2016-02-01T12:24:55.785-06:00","updated_at":"2017-12-13T14:05:58.630-06:00","hashtags":[],"usernames":["IllinoisRivals","IlliniFootball","IlliniMBB","sturdy32"],"max_number":4}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice/printable' site-name='OrangeandBlueNews.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733101', 'https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Supinie: Illini football recruiting has some juice";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":112,"image_id":1796724,"url":"https://seatgeek.com/illinois-fighting-illini-football-tickets","position":1,"site_id":49,"created_at":"2016-04-06T09:18:14.037-05:00","updated_at":"2017-06-29T15:25:11.252-05:00","image_url":"https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/pejibwu5z93wcphtcsl1"}' class='ad-one'></rv-custom-ad>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://illinois.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733101",
    c7: "https://illinois.rivals.com/news/supinie-illini-football-recruiting-has-some-juice"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fillinois.rivals.com%2Fnews%2Fsupinie-illini-football-recruiting-has-some-juice&c5=2022733101&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
